Jump to content

Clutch lever not moving after sprockets and chain replacement


Recommended Posts

I removed the front sprocket cover, and now my clutch lever is impossible to pull in.  Also the pin into the slave cylinder seems to be out too far.  Is that the lifter? I am new at this but learning through the forums so any help is appreciated.  This is a 2007 RWB Anniversary nonABS.  Air in the line?  I am 3rd owner and just turned 50K so thinking I should bleed and replace parts anyway, but if there are any other possible causes, help is again appreciated!

Link to comment
Share on other sites

  • Member Contributer

When you removed the sprocket cover did you clamp the clutch slave cylinder to stop it coming out too far? If not then it may be beyond its normal operation range you may have to remove it and the reseat it. 

  • Like 1
Link to comment
Share on other sites

4 hours ago, RRluv2RIDE said:

Also the pin into the slave cylinder seems to be out too far.  Is that the lifter?

Yes, so it may not be fully seated into the pressure plate.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.