Jump to content

eochs

Members
  • Posts

    3
  • Joined

  • Last visited

Profile Information

  • Location
    Victoria, BC
  • In My Garage:
    VFR750F 1996

Recent Profile Visitors

43 profile views

eochs's Achievements

Newbie

Newbie (1/14)

  • First Post
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. Ok, that is all the encouragment I need. The British unit has a working speedo/odo(MPH), but the printed circuit board on back looks bad. My original cluster (in KM) is in very good shape there. I'm going to reassemble with the best parts of both clusters, and retest.... Done! And voila the issues are mostly resolved, but the speedo is incorrect yet! Its counting miles now, but under counting them. Same error ratio as with the British instrument cluster. My Canadian Cluster had much less corrosion, and so everything seems to work fine, except the clock which fell apart when I popped it out of the circuit board. Sigh. Do I need a matched electronic sender to make it read right??
  2. Ok, that is all the encouragment I need. The British unit has a working speedo/odo(MPH), but the printed circuit board on back looks bad. My original cluster (in KM) is in very good shape there. I'm going to reassemble with the best parts of both clusters, and retest....
  3. Ok, my odo was doa, so I bought a used instrument cluster from old Blighty, I'm in Canada. I swapped instrument clusters whole, no mods, and noticed the following strange things: the high beam shows blue indicator when lights are on low beam, and then when on high beam the indicator light is off. The blinker lights are "on" on the dashboard, and then flash when active, otherwise working fine. Finally, the odometer read 6.8miles after a 9.0 miles trip. And the speedo seemed to under represent my speed. Never seemed to go past 40MPH, even though I swear I was doing 50plus. Hmmm, any ideas folks?? I'm thinking the sensor sender on the speedo circuit needs to be matched with the MPH instrument cluster? No idea actually,.... My next move was going to be to take the tach/odo off the british cluster, and insert it into my Canadian cluster...
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.