Jump to content

Electrically dead '92 VFR


sjensen30
 Share

Recommended Posts

     I have a friend who, when starting her '92 VFR, hit the start button and there was a big POP and the bike went dead. Can anyone give me some leads on what I should be looking for to repair the poor thing! I can't stand a dead VFR!! I haven't had a chance to dig into it and any information that you can send my way would be greatly appreciated!  Steve

Link to comment
Share on other sites

Sounds like the main fuse popped or the battery terminals are loose.  Or both.  Main fuse should be located on the starter solenoid, trace the positive cable back to it.

  • Like 1
Link to comment
Share on other sites

What he said, 30amp fuse next to the battery (starter relay) probably shorted regulator rectifier wires, see if there is a melted mess on the right side of the bike where the r/r is mounted and check the white plug with the 3 yellows/1black/1red.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.