Jump to content

Archived

This topic is now archived and is closed to further replies.

VFREagle

No headlights and other weird electrical stuff going on

Recommended Posts

Hi all

 

My 2005 ABS has got no headlights, no hi beam, buzzing hi beam relay, no front turn signals. Problem started with blown left headlight and then a day later relay buzzing and another day later no lights. All other electrics appear OK.

 

I've done the usual visual checks and cleaned switches with contact cleaner and swapped Hi/low relays out but no change.

 

Any ideas on where I go next?

 

Thanks in advance

 

 

Share this post


Link to post
Share on other sites
36 minutes ago, VFREagle said:

Hi all

 

My 2005 ABS has got no headlights, no hi beam, buzzing hi beam relay, no front turn signals. Problem started with blown left headlight and then a day later relay buzzing and another day later no lights. All other electrics appear OK.

 

I've done the usual visual checks and cleaned switches with contact cleaner and swapped Hi/low relays out but no change.

 

Any ideas on where I go next?

 

Thanks in advance

 

 

Yep. Green earth wire on your blue connector left side requires better earthing, common problem, but an easy fix. See picture. 

Cheers.

IMG_5314_3_1.jpg

Share this post


Link to post
Share on other sites

Thanks for reply Grum. I'll patch a new earth to test it out.

 

Is that the wire on the actual bulb connector that is the usual culprit?

Share this post


Link to post
Share on other sites

No, not a bulb connector, it's a major connector for all your front services, relays, bank angle sensor, turn signal relay and some Instrument Panel stuff, the green wire is the ground for all those services.

 

You won't have any trouble finding the blue connector. You can make this mod even easier as only the forward earth wire of the blue connector requires a good ground point, picture shows that the same wire on both sides of the connector is being grounded. A good solid ground at this point should solve your issues.

 

Also your 2005 is a 6gen not a 5th.

Good luck with the mod and lets know how you get on.

Cheers.

Share this post


Link to post
Share on other sites

Further Upstream from that blue connector hidden in the front wiring harness under the black electrical tape they use to wrap the wiring loom along the left hand side branch of the front fairing stay or bracket there is a common ground bus connector which is famous for failing even if it looks optically okay check this thread and do the mod...

https://scontent.fmad3-4.fna.fbcdn.net/v/t1.0-9/fr/cp0/e15/q65/36914223_2259554630938904_766663056884236288_o.jpg?_nc_cat=0&efg=eyJpIjoidCJ9&oh=32d146f7afd63ceac7e7f40dac795776&oe=5BCFBFDC

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.