Jump to content

gunn799

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

1 Neutral

About gunn799

  • Rank
    Local Racer

Profile Information

  • Location
    CA

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. That's a relief, I thought the shaft may have bent but everything runs true. I think it may be the source of my vibration I'm experiencing at...um..."higher" speeds. Also should you replaced chain and sprockets together or can you get away from doing that if the sprockets still have decent flat lands at the tips of the teeth? Sent from my SM-G930W8 using Tapatalk
  2. My brake hose bracket is under the bolt still so thats good. What's weird is when I spin the wheel the chain has a spot where it goes really tight but then loosesns back to normal. Despite my efforts to revive the chain and sprockets which the po neglected, I think they're done. Sent from my SM-G930W8 using Tapatalk
  3. Since I'm on the topic of chains, I've noticed that the drive chain isn't staying adjusted after a ride. There's just too much slack there. The chain is rubbing on the plastic guards on the swingarm. Am I missing something here? Sent from my SM-G930W8 using Tapatalk
  4. I bought them but haven't installed yet. Just wondering if anyone has used these with positive results. There are 2 objectives here, the first obviously getting rid of the stock tensioners, and the other is to cure the rattle caused by failed tensioner(s). Interestingly enough, my recent oil change with Amsoil Metric 10w40 seemed to help quite a bit with the rattle. Sent from my SM-G930W8 using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.