Jump to content

bsmilen2

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bsmilen2

  • Rank
    New Member

Profile Information

  • Location
    Salt Lake City, UT

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. So it happened a couple of weeks ago. I was riding it all day back and forth a couple of miles to school and back. The bike would start fine, I started it at least 3 times that day. I let it sit for a couple of hours and when I come back to it, it would not start. I had to put it in my truck and get it back to my house. I put the battery on a trickle charger and I wait a couple of days, it starts right up. I took it off the trickle charger and let it sit to see if the battery could hold a charge. The battery couldn't hold a charge so I replaced it. It started as soon as I put a new batter in it. After that first start it wouldn't start again, so again I put it on a trickle charger and I got it started and rode it to a different place, where I couldn't get it started again. I tried to turn it on at this different place and the fuel pump wouldn't prime every time I turned the ignition key. There was one moment where I got the fuel pump to prime, but then it didn't happen again for a week. I took it in to my local Honda shop and they say it's the ECM I need to replace and they want to do it for $900. I would rather not do that. Has anyone had a similar problem that was fixed without replacing the ECM? Is there anything that I should ask them to check before that gets replaced?
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.