Jump to content
Sign in to follow this  
9C1

Burning up?

Recommended Posts

Every time I get off my 2000 VFR, I get a good whiff of what smells like grass or leaves burning.  Never any smoke.  I've lifted the tank, checked the airbox, checked the battery compartment, and looked at the engine as best I can see but don't see anything.  Bike runs great, so no issues there.  Anyone else have this happen?  Thoughts? 

Share this post


Link to post
Share on other sites

Is something nesting in the "V" of the engine?

Share this post


Link to post
Share on other sites

Maybe there's a bit of coolant leaking, it has a distinctive smell to it when it's hot.  Have a look into the "V" as best you can after a ride.

 

Also look at the little hole on the bottom of the water pump.

Share this post


Link to post
Share on other sites

Certain time of year I'd collect a few Locusts on the oil cooler. Yummo smelt like Kentucky Fried on the go!

Check if you've collected any critters around the radiator core or oil cooler.

Cheers:beer:

Share this post


Link to post
Share on other sites

Thanks, fellas.  I'll get a closer look at the V and the coolant lines.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.