Jump to content
Bigdan

Gear selector indicator...

Recommended Posts

Twice today my gear display has vanished only to display a horizontal line.  The bike runs fine. The second instance a quick off/on returned the gear display to normal.   Has any one else encountered this issue?

Share this post


Link to post
Share on other sites

Yeah I've had it happen only a couple of times in 63,000k's, seems to sort itself out quickly, don't think it's anything to worry about.

Apart from the 3 gear logic switches, it also uses speed and rpm for gear indication, guess on the odd occassion it just gets itself a little confused. 

Are you using standard size sprockets?

Share this post


Link to post
Share on other sites

I get it sometimes when I shift without enough force, and it sort of finds gear despite me instead of because of me, if that makes sense.

Share this post


Link to post
Share on other sites

Mine does that if there's slight pressure on the gear lever, like you've changed up and left your boot underneath it lifting it slightly rather than releasing it completely. As Grum says, it always sorts itself out quickly when it redoes its calculations.

Share this post


Link to post
Share on other sites

Mine does it too when I do a lazy shift.  Shift properly and deliberately and it isn't an issue.  That's my experience.  

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

okay thanks all, yes still on the standard sprockets.  Maybe my change from adv Sidi boots and now using a sidi track boot is taking time for me to get used to.  I have found my shifts to be much more easier because of the lower profile boot and subsequently likely I’am not shifting properly with enough force.

  • Like 1

Share this post


Link to post
Share on other sites

It’s down to operator error, I’m still doing it after riding the bike for years.

Share this post


Link to post
Share on other sites

First time it happened to me I pulled over to try to figure out what the bike was telling me. Turned it off and restarted the bike and figured it out.

Share this post


Link to post
Share on other sites

I had the gear indicator drop out on me this morning. I was downshifting to avoid traffic and it’s not have done it forcefully enough. Once I shifted again and it had time to think, the indicator returned.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.