Welcome to VFRDiscussion

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Doc4216

I Think Its The R/r

30 posts in this topic

Thanks for the advice


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

And the battle continues!

I fully expected to have to replace the stator today. What I didn't expect, was to have to replace the R/r also. So, I am changing the stator, r/r, and doing oil change again for the second time in two years :(a25542a2032f4557ab3d96016b877a8f.jpg124d57c8bba1d16cb1fa3ce4ab9d745f.jpg740f2651d7a8f1457167575bd3434c7c.jpg

1 person likes this

Share this post


Link to post
Share on other sites

If you don't get rid of that connector, you'll be replacing it all again soon enough.  

As has been stated on this site a thousand times, that connection needs to be soldered.  

Share this post


Link to post
Share on other sites
2 hours ago, VFROZ said:

If you don't get rid of that connector, you'll be replacing it all again soon enough.  

As has been stated on this site a thousand times, that connection needs to be soldered.  

Roger that! 

 

Will try try that next, since as I tried to start and test, my dash starting blinking. Now on to troubleshoot mode.

Share this post


Link to post
Share on other sites
And the battle continues!

I fully expected to have to replace the stator today. What I didn't expect, was to have to replace the R/r also. So, I am changing the stator, r/r, and doing oil change again for the second time in two years :(a25542a2032f4557ab3d96016b877a8f.jpg124d57c8bba1d16cb1fa3ce4ab9d745f.jpg740f2651d7a8f1457167575bd3434c7c.jpg

Dang that sucker is toast!!!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now